Die Power von Excel nutzen und anwenden

Klick den Tipp!


Bilderauswahl

Video - Matrixformeln

excelmx

Video - Dynamische Diagramme

 

excel2010dyd

 

Video - Diagrammerstellung


exceldiagramme

Microsoft Award 2011

Microsoft Community Contributor

SVERWEIS() mit mehreren Suchergebnissen Drucken
Fragen und Antworten zu Excel - Formeln und Funktionen
Geschrieben von: Frank Arendt-Theilen   

 

Die Funktion SVERWEIS() gibt mir nur die erste Fundstelle eines Suchwertes zurück. Wie lautet die Formel in Excel, die mir alle Fundstellen zurückliefert?

Gegeben Sei die folgende Ausgangssituation:

  • In Spalte A stehen die Vornamen und in Spalte B die Nachnamen
  • In Zelle E1 wird der Vorname eingegeben, von dem der Nachname gesucht werden soll.

Die Funktion SVERWEIS() würde bei diesem Beispiel nur den Nachnamen Schuster finden.


Ausgangssituation für den SVERWEIS() mit mehreren Ergebnissen


Der Vorname Petra ist aber in der Spalte A mehrere Male enthalten. Mit einer Matrixformel können alle Nachnamen zurückgegeben werden, deren Vorname Petra ist.

  • Markieren Sie die Zelle E3 und geben Sie die folgende Formel ein:

    =WENNFEHLER(INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=$E$1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;$E$1)+1-ZEILE(A1)));"")
  • Schließen Sie die Eingabe mit der Tastenkombination Strg+Umsch+Enter ab. Excel umgibt automatisch die Formel mit geschweiften Klammern und kennzeichnet sie damit als Matrixformel.
  • Kopieren Sie die Formelzellen soweit herunter, bis sich Leerzellen ergeben.

 

Anmerkung:

Für die Vorgängerversionen von Excel 2010 lautet die Formel:

=WENN(ISTFEHLER(INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=$E$1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;$E$1)+1-ZEILE(A1))));"";INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=$E$1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;$E$1)+1-ZEILE(A1))))

Schließen Sie auch diese Formeleingabe mit der Tastenkombination Strg+Umsch+Enter ab.

 

Zuletzt aktualisiert am Mittwoch, den 24. April 2013 um 11:40 Uhr
 

Heute

Montag, 18. Dezember 2017

Video - Management-Reports

 

excel2013report

 

Video - Bedingte Formatierung


excel2010v2bbf


Buch - Bedingte Formatierung

ExcelBedingteFormatierung

Office2010-Blog


Office2010-Blog Logo

Hinweis

Fast alle Hardware- und Software- bezeichnungen, die auf dieser Web- site erwähnt werden, sind gleichzeitig eingetragene Warenzeichen und sollten als solche behandelt werden.

Video2Brain-Autor

v2bautor