Die Power von Excel nutzen und anwenden

Klick den Tipp!


Bilderauswahl

Video - Matrixformeln

excelmx

Video - Dynamische Diagramme

 

excel2010dyd

 

Video - Diagrammerstellung


exceldiagramme

Microsoft Award 2011

Microsoft Community Contributor

Differenz zwischen Uhrzeiten Drucken
Fragen und Antworten zu Excel - Datum und Uhrzeit
Geschrieben von: Frank Arendt-Theilen   

 

Wie kann ich die Differenz zwischen zwei Uhrzeitwerten berechnen?

Da Excel jedem gültigen Uhrzeitwert eine serielle Zahl zuordnet, kann mit diesen Uhrzeitwerten ganz normal gerechnet werden. Angenommen in Zelle A1 steht die Uhrzeit 18:00:00 und in Zelle B1 06:30:00, dann berechnen Sie die Differenz beider Uhrzeitwerte mit der Formel

=A1-B1


Excel weist automatisch der Formelzelle ein Uhrzeitformat zu. Sie erhalten als Ergebnis für das obige Beispiel 11:30:00.

 

Sollte bei der Berechnung ein negativer Werte ermittelt worden sein, dann gibt Excel die Zeichenfolge '#########' aus. Ein negativer Uhrzeitwert wird im 1900-Datumswertesystem nicht unterstützt. Diesem Problem können Sie auf verschiedene Weise begegnen.

  1. Ist Ihnen das Vorzeichen des ermittelten Uhrzeitwertes egal, benutzen Sie die Formel

    =ABS(A1-B1)
  2. Die Funktion ABS() liefert Ihnen den absoluten, also vorzeichenlosen Wert der Zahl, die Sie als Argument übergeben haben. Steht in Zelle A1 der Uhrzeitwert 07:45:00 und in Zelle B1 der Uhrzeitwert 18:00:00 erhalten Sie mit der obigen Formel als Ergebnis: 10:15:00 (10 Stunden und 15 Minuten).

  3. Möchten Sie das Vorzeichen mit angezeigt bekommen, ermitteln Sie zunächst, ob die Differenz der beiden Uhrzeitwerte positiv oder negativ ist und formatieren den errechneten Uhrzeitwert mit Hilfe der Funktion TEXT().

    Beispiel:
    In Zelle A1 steht 06:30:00 und in Zelle B1 18:00:00, dann lautet die Formel:

    =WENN(A1-B1<0;"- "&TEXT(A1-B1;"hh:mm:ss");"+ "&TEXT(A1-B1;"hh:mm:ss"))

    Als Ergebnis erhalten Sie: - 11:30:00.
    Mit dieser "Text"-Uhrzeit können Sie mit der folgenden Formel weiterrechnen, wenn die vorhergehende Formel in Zelle C1 steht:

    =ZEITWERT(RECHTS(C1;8))

    Formatieren Sie abschliessend die Ergebniszelle in einem Uhrzeitformat.

  4. Abschließend können Sie in den Excel-Optionen das 1904-Datumswertesystem aktivieren. Die ermittelte Differenz wird dann mit Vorzeichen angezeigt (nicht empfehlenswert!)

    Wichtig:

    Haben Sie bereits Datumswerte in ein Tabellenblatt eingetragen, dann werden diese beim Umstellen des Datumswertesystems um vier Jahre und einen Tag versetzt dargestellt.
Zuletzt aktualisiert am Sonntag, den 03. November 2013 um 19:39 Uhr
 

Heute

Dienstag, 17. Oktober 2017

Video - Management-Reports

 

excel2013report

 

Video - Bedingte Formatierung


excel2010v2bbf


Buch - Bedingte Formatierung

ExcelBedingteFormatierung

Office2010-Blog


Office2010-Blog Logo

Hinweis

Fast alle Hardware- und Software- bezeichnungen, die auf dieser Web- site erwähnt werden, sind gleichzeitig eingetragene Warenzeichen und sollten als solche behandelt werden.

Video2Brain-Autor

v2bautor